Display full size of 1st file/image only in Item Show view?

Hello. I am using Berlin on this site: www.ocfallenheroes.org, running Omeka 2.1.2.

When the Item File Gallery option in the theme configuration is checked, is there any way in Item Show view to still show a full-size version of just the 1st file? I don't want full sizes displayed for all files (they stack up on each other), just the 1st file associated with each Item.

I use this method in another site, but the Items on that site ONLY have 1 file associated with each Item.


I haven't tried this yet, but I think this is at least one possible approach.

You could use the file_markup($files, $options) function to display different files in different ways by passing directly in an array of files. So, instead of the line <?php echo files_for_item(); ?>, do:

$itemFiles = $item->Files;
//display the first one fullsize
echo file_markup($itemFiles[0], array('imageSize'=>'fullsize'));
//get rid of the first one
//display the rest as usual
echo file_markup($itemFiles);

Update: Oops. Looks like you are using Seasons, not Berlin on that site? In that case, the line to replace is <?php echo item_image_gallery(); ?> However, a lot of the HTML markup will be lost, and so might have to be rebuilt in your (awesome!) customizations.

Sorry about that. Yes, I'm using Seasons. I'll give this a try this weekend. And thanks for the compliment!

@patrickmj That script didn't quite do the trick, but it's still a nicer output than a bunch of full-size image files stacked up on top of each other. And I had to remove the Lightbox code solution (that you recently documented) that used the <?php echo item_image_gallery(); ?> you had me replace.

Example output with Seasons Item File Gallery setting checked.

Example output with Seasons Item File Gallery setting unchecked.