disable register_globals?


I'm attempting an install and got the (expected?) warning that the register_globals is enabled and that
It is recommended (but not required) that [I] disable register_globals for [my] Omeka installation.

I contacted my host support (I am using ICDsoft) and they told me I should create a file called php.ini and place it "a copy of the php.ini file in every directory where [I] need to disable register_globals."

Which directory should this php.ini file be placed? Or is there another way I can disable the register_globals?


Hi Madeline,

We actually do have a setting near the top of the .htaccess file at the root of Omeka, that has php_flag register_globals off. Seems like your host isn't recognizing that flag.

Turning off register_globals isn't required. Are you able to install Omeka anyways?


Hey Jeremy,

Thanks for your response. I am now wrestling the MySQL, getting the message >>Access denied for user: 'ycpwrt@localhost' to database 'ycpwrt_omeka'<<

My support with ICDsoft told me to install the following php.ini file in every directory that runs php:

register_globals = off
post_max_size = 20M
memory_limit = 200M
upload_max_filesize = 20M
max_execution_time = 120
expose_php = off
session.save_path = /tmp
mysql.default_socket = /tmp/mysql5.sock
mysqli.default_socket = /tmp/mysql5.sock

My support people say this:

>>This will disable register_globals, and will change the default socket for the MySQL connection to the correct one. You should leave just "localhost" in your db.ini file. The downside of this method is that you have to copy the php.ini file to each directory where PHP scripts will be executed.

I'm not sure if the register_globals problem is related to the access denied problem. I'm trying the php.ini file thing right now, and will report back.


Also, my .htaccess files don't have anything about the register_globals... can I add that in? Could you show me what the code should look like?



Here's what the .htaccess file would look like in your root directory for Omeka 1.1:


Look for this line of code:

php_flag register_globals off