CSV import - "settings expired" error

Hi, I notice there have been several other posts about this, but looking through the responses to those I haven't yet found a fix that works for me. Any pointers you folks could give me would be very gratefully received--I'm pretty new to all of this.

I had been able to use CSV import on Omeka.net successfully with the same files, but now that I am using Omeka.org I am consistently getting an error.

When clicking "Next" on the very first step of CSV import in Omeka 2.0.2, I am getting the error message "Import setting expired. Please try again." I have tried in multiple browsers (Firefox, Chrome, Chromium, and Midori) with the same result.

I am using Ubuntu 11.04 in a VMware player.


I notice that this plugin can handle some Windows special characters but not others. It doesn't seem to have problems with smart quotes but it chokes (saying 'Import settings expired') on strings of dots (octal 205) and short dashes (octal 226). This looks like a simple bug in the plugin. In the meantime I am making sure that in the .csv files I upload these special characters have already been converted to their text/HTML equivalents.

Usually when you're having problems with special characters it's a sign that the file isn't saved in UTF-8 format, which is what the plugin's expecting.

It's actually surprisingly difficult to get Excel to save a CSV file as UTF-8. OpenOffice and LibreOffice let you pick the output encoding outright, though.

Hi...I got the same error, but I think my problem is the file size is on the limit or bigger than the limit size of 64MB. This file that I got error is exactly 64MB. How can I increase the limit file size? is this in php.ini? I can't find the seetings in CSV Import plugin.

Thanks for your help ;)


Yes, usually that setting is in the php.ini file. Another thing to try, of course, is to break the CSV file into a few separate files and import them in sequence.

Thanks Patrick...can't split the file, because it's only 1 item, but with hundreds image attach to it ;(

Impossible to attach them manually...is any one in this forum ever have to deal with this kind of problem before? What is the best solution?



Ah, that is sticky! Best bet in that case is probably to look in php.ini for the max upload and bump that up.

Thanks Patrick ;)