CSV Import Problem

I am trying to import a CSV file but when I installed the plugin I can't seem to get to the plugin's page. I see the CSV Import link in my MyOmeka page but when I click on it, it doesn't load. If someone needs to log in to see the problem, I can provide an access account.

I have reinstalled Omeka 1.3 and I am still having problems. I looked at the video on Vimeo regarding CSV import and when I did the configure thing, I did not see the "Path to PHP-CLI". Our organization is using BlueHost.com and my web coding knowledge is pretty limited.

The "Path to PHP-CLI" configuration option is no longer part of the CSV Import plugin, it is now contained in application/config/config.ini.

Bluehost (or some Bluehost user on the forums) should be able to tell you what should go in that configuration option.

However, I'm not sure that's the cause of your problem. Could you try the steps listed at this Codex page? If Omeka or your server is encountering an error, the steps on that page should help you get a message you can post here.

I did that and I am not getting any error messages, the page just hangs and doesn't load.

Hello All,

I haven't heard from anyone and I have looked at the forums and I do not seem to see a straightforward answer to the hanging issue. It seems to be that this plugin works for some but not others. That some are an easy fix and others are not ... is there a way in which to simplify it such that there could be a much more straightforward path to fixing it. Also, I can provide anyone with login credentials if you need to poke around the C-Panel of this Bluehost server.


I found that if my csv files have quite lengthy/complicated text in them (e.g. transcriptions for an interview) then they won't import. Probably because there's too much punctuation in the extended text that's being read as part of the csv.

Does it still hang if you use a really simple csv file, e.g. with a couple of words per column and no punctuation?

Hi Pcoutas,

I am not even able to get to that step. It starts hanging once I click on the tab for CSV import. Besides, the actual file I plan to import does not include transcriptions.

I tried to install the OaipmhHarvester plugin and I got the following error which is similar to one that I got from the CSV import some time ago but haven't been able to replicate.

"Omeka Has Encountered an Error

User jtarchiv_gspiro already has more than 'max_user_connections' active connections

#0 /home4/jtarchiv/public_html/application/libraries/Zend/Db/Adapter/Abstract.php(448): Zend_Db_Adapter_Mysqli->_connect()
#1 /home4/jtarchiv/public_html/application/libraries/Zend/Db/Adapter/Abstract.php(782): Zend_Db_Adapter_Abstract->query('SELECT name, va...', Array)
#2 /home4/jtarchiv/public_html/application/libraries/Omeka/Db.php(82): Zend_Db_Adapter_Abstract->fetchPairs('SELECT name, va...')
#3 /home4/jtarchiv/public_html/application/libraries/Omeka/Core/Resource/Options.php(39): Omeka_Db->__call(Array, Array)
#4 /home4/jtarchiv/public_html/application/libraries/Omeka/Core/Resource/Options.php(39): Omeka_Db->fetchPairs('fetchPairs', Array)
#5 /home4/jtarchiv/public_html/application/libraries/Zend/Application/Bootstrap/BootstrapAbstract.php(676): Omeka_Core_Resource_Options->init('SELECT name, va...')
#6 /home4/jtarchiv/public_html/application/libraries/Zend/Application/Bootstrap/BootstrapAbstract.php(622): Zend_Application_Bootstrap_BootstrapAbstract->_executeResource()
#7 /home4/jtarchiv/public_html/application/libraries/Zend/Application/Bootstrap/BootstrapAbstract.php(579): Zend_Application_Bootstrap_BootstrapAbstract->_bootstrap('Options')
#8 /home4/jtarchiv/public_html/application/libraries/Omeka/Core/Resource/Pluginbroker.php(29): Zend_Application_Bootstrap_BootstrapAbstract->bootstrap('Options')
#9 /home4/jtarchiv/public_html/application/libraries/Zend/Application/Bootstrap/BootstrapAbstract.php(676): Omeka_Core_Resource_Pluginbroker->init('Options')
#10 /home4/jtarchiv/public_html/application/libraries/Zend/Application/Bootstrap/BootstrapAbstract.php(622): Zend_Application_Bootstrap_BootstrapAbstract->_executeResource()
#11 /home4/jtarchiv/public_html/application/libraries/Zend/Application/Bootstrap/BootstrapAbstract.php(579): Zend_Application_Bootstrap_BootstrapAbstract->_bootstrap('PluginBroker')
#12 /home4/jtarchiv/public_html/application/libraries/Omeka/Core/Resource/Frontcontroller.php(42): Zend_Application_Bootstrap_BootstrapAbstract->bootstrap('PluginBroker')
#13 /home4/jtarchiv/public_html/application/libraries/Zend/Application/Bootstrap/BootstrapAbstract.php(676): Omeka_Core_Resource_Frontcontroller->init('PluginBroker')
#14 /home4/jtarchiv/public_html/application/libraries/Zend/Application/Bootstrap/BootstrapAbstract.php(619): Zend_Application_Bootstrap_BootstrapAbstract->_executeResource()
#15 /home4/jtarchiv/public_html/application/libraries/Zend/Application/Bootstrap/BootstrapAbstract.php(579): Zend_Application_Bootstrap_BootstrapAbstract->_bootstrap('frontcontroller')
#16 /home4/jtarchiv/public_html/application/libraries/Zend/Application.php(347): Zend_Application_Bootstrap_BootstrapAbstract->bootstrap(NULL)
#17 /home4/jtarchiv/public_html/application/libraries/Omeka/Core.php(114): Zend_Application->bootstrap(NULL)
#18 /home4/jtarchiv/public_html/admin/index.php(37): Omeka_Core->initialize()
#19 {main}"

Hola thegspiro,
si sigues con el problema del CVS import 1.3,
debes cambiar el path de PHP-CLI en el archivo application/config/config.ini por /usr/local/bin/php que es la ruta para Bluehost.

Hello JPMoyar,

Thank you for your help. I looked at that page and I added the "/usr/local/bin/php" to the page and I now get the following error.

"Your PHP-CLI path setting is invalid.

Please change the setting in /home4/jtarchiv/public_html/application/config/config.ini

If you do not know how to do this, please check with your system or server administrator."

I don't know what the specific value should be but here are the two references to the "PHP-CLI";

"; Path to PHP-CLI for running background processes. Set this to a path to override the autodetected PHP path.
background.php.path = "/usr/local/bin/php""

"; Path to PHP-CLI for running background processes. Set this to a path to override the autodetected PHP path.
background.php.path = ";;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;"


I was having this exact same problem, and I fixed it, so I am providing a summary here in case anyone else has the same issue.

I am using Bluehost. I installed the CSV Import plugin. When I tried to access the plugin by clicking on the tab in the admin site, the page would not load. Also, after clicking on the CSV tab, I would not be able to load any other pages in the admin site. I had to log out, close my browser, and delete the history in order to access the site again.

Here is what I did to fix it, based on the information in this current thread (and this older thread: http://omeka.org/forums/topic/csv-import-hangs)

Using an FTP client, I accessed this file in my Omeka directory: application/config/config.ini

In the file, I changed this line:
; Path to PHP-CLI for running background processes. Set this to a path to override the autodetected PHP path.
background.php.path = ""

To this:
; Path to PHP-CLI for running background processes. Set this to a path to override the autodetected PHP path.
background.php.path = "/usr/local/bin/php"

That fixed the problem for me.

I was also having the same problem using Hostgator. I uploaded the CSVImport to my plugins directory, and then installed it in the settings on the admin page and it said it installed successfully. However, when I clicked on the new "CSV Import" tab on the admin page, it never loaded and I got a 500 Internal Server error. The Hostgator cPanel had a process "/usr/bin/php -v" that I couldn't kill unless I deleted the CSVImport from the plugins directory. Fortunately, Amber's fix seems to have worked for me. Thanks, Amber!