CSV import plugin feedback and possible bug

I just successfully completed a CSV import and noticed a few things which I think may be worth passing on for other beginners like myself. This is based on Omeka v1.4.1 and the v1.3 of the CSV Import plugin.

First, it's apparently not necessary (as stated in the CSV Import screencast from Omeka 1.0) to double-quote field data with spaces in it. I was able to import field data with spaces in the text with no issues.

Second, in Office 2011 for the Mac, Excel creates a CSV file delimited with semicolons. Not sure why this is happening. Perhaps because some of my language options are in German? In any case, these need to be replaced before using the file in Omeka.

Finally, Excel exports from Office 2011 Mac by default with Western Mac (Mac OS Roman) encoding. I presume it is as a result of this (?) that when the importer reached field data with an umlaut in it, it stopped and didn't include the rest of the name. Specifically, the Title "Deutsche Film und Weltb├╝hne" was imported as "Deutsche Film und Weltb". I presume this is a bug? I haven't yet tested with a UTF-8 encoded CSV file but will try this the next time I use the plugin and append to this post if this fixes the problem.

Thanks for the feedback.

Regarding the semicolons instead of commas, my guess is that somewhere there's an option to use commas instead. However, I'll have to find someone with that version to check for sure.

Character encoding is often an adventure. Hopefully UTF-8 works more better. Will look forward to hearing your results.