CSV import error

I was able to import CSV records for items. All this past week when I try it, I get the following error message: "Import settings expired. Please try again".

I uninstalled and reinstalled the plugin, and still get the error message.

I have the same the same error message here. Been trying to figure out what is wrong but so far no luck. I will post back if I find a fix. Does anyone else know what may be happening that would cause this message to come up? I have previously uploaded without error so I am a bit confused.. Below is my system information
Browser: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.4 (KHTML, like Gecko) Chrome/22.0.1229.79 Safari/537.4
Role: super

Omeka: 1.5.2
PHP: 5.3.10-1ubuntu3.2 (apache2handler)
OS: Linux 3.2.0-26-generic x86_64
MySQL Server: 5.5.24
MySQL Client: 5.5.24
Apache: Apache/2.2.22 (Ubuntu)

PHP Extensions
Regular: apache2handler, bcmath, bz2, calendar, Core, ctype, date, dba, dom, ereg, exif, fileinfo, filter, ftp, gd, gettext, hash, iconv, json, libxml, mbstring, mcrypt, mhash, mysql, mysqli, openssl, pcre, PDO, pdo_mysql, Phar, posix, Reflection, session, shmop, SimpleXML, soap, sockets, SPL, standard, sysvmsg, sysvsem, sysvshm, tokenizer, wddx, xml, xmlreader, xmlwriter, zip, zlib

CsvImport: 1.3.4
Geolocation: 1.2
MyOmeka: 1.0.1 (inactive)

Minimalist Omeka Theme:1.2
Rhythm: 1.3 (current)
Seasons: 1.3
Thanks, Roy: 1.5

I think when I got this error that it was because I hadn't formatted my csv file in UTF-8. UTF-8 isn't the default in the drop-down menu in Open Office when saving as csv, and I'm lazy to select something that's not default. I retraced my steps and saved as UTF-8.

Not formatting in UTF-8 had not caused an error with previous imports. But the import I was working with when I posted this had some cells with much longer values (ie. long values for the Description fields).

I saved my CSV to UTF-8 and the import went through fine.

Thanks for the update, I have now got past the "Import settings expired. Please try again" error. I have since enabled logging and I am now getting the following. I have found that the CSV file will go through when I do not populate it with the information regarding the file, which is shown in the file as

Thanks to one and all for any help you can offer.

Error messages I get after import.

Omeka has encountered an error


'' cannot be read: The server returned code '403'

#0 /var/www/omeka/application/libraries/Omeka/File/Ingest/Source.php(128): Omeka_File_Ingest_Url->_transfer('http://192.168....', '/tmp/c6cb7a8a1a...', Array)
#1 /var/www/omeka/application/libraries/Omeka/File/Ingest/Abstract.php(176): Omeka_File_Ingest_Source->_transferFile(Array, 'http://192.168....')
#2 /var/www/omeka/application/models/ItemBuilder.php(209): Omeka_File_Ingest_Abstract->ingest('http://192.168....')
#3 /var/www/omeka/application/libraries/globals.php(505): ItemBuilder->addFiles('Url', 'http://192.168....', Array)
#4 /var/www/omeka/plugins/CsvImport/models/CsvImport/Import.php(366): insert_files_for_item(Object(Item), 'Url', 'http://192.168....', Array)
#5 /var/www/omeka/plugins/CsvImport/models/CsvImport/Import.php(261): CsvImport_Import->_addItemFromRow(Array, Array, Object(CsvImport_ColumnMap_Set))
#6 /var/www/omeka/plugins/CsvImport/models/CsvImport/Import.php(203): CsvImport_Import->_importLoop(0)
#7 [internal function]: CsvImport_Import->start()
#8 /var/www/omeka/plugins/CsvImport/models/CsvImport/ImportTask.php(22): call_user_func(Array)
#9 /var/www/omeka/application/libraries/Omeka/Job/Dispatcher/Adapter/Synchronous.php(25): CsvImport_ImportTask->perform()
#10 /var/www/omeka/application/libraries/Omeka/Job/Dispatcher/Default.php(95): Omeka_Job_Dispatcher_Adapter_Synchronous->send('{"className":"C...', Array)
#11 /var/www/omeka/plugins/CsvImport/controllers/IndexController.php(138): Omeka_Job_Dispatcher_Default->send('CsvImport_Impor...', Array)
#12 /var/www/omeka/application/libraries/Zend/Controller/Action.php(516): CsvImport_IndexController->mapColumnsAction()
#13 /var/www/omeka/application/libraries/Zend/Controller/Dispatcher/Standard.php(295): Zend_Controller_Action->dispatch('mapColumnsActio...')
#14 /var/www/omeka/application/libraries/Zend/Controller/Front.php(954): Zend_Controller_Dispatcher_Standard->dispatch(Object(Zend_Controller_Request_Http), Object(Zend_Controller_Response_Http))
#15 /var/www/omeka/application/libraries/Zend/Application/Bootstrap/Bootstrap.php(97): Zend_Controller_Front->dispatch()
#16 /var/www/omeka/application/libraries/Zend/Application.php(366): Zend_Application_Bootstrap_Bootstrap->run()
#17 /var/www/omeka/application/libraries/Omeka/Core.php(165): Zend_Application->run()
#18 /var/www/omeka/admin/index.php(44): Omeka_Core->run()
#19 {main}

Are the files you're trying to link to in the CSV hosted locally on your machine, or are they on a non-public server? That could be why the CSV Import fails when it tries to import that file. I can't see the file you posted, because the connection times out.

Hi Sheila
Thanks for the quick response. The images are hosted on the Ubuntu server running Omeka. I think I have my problems ironed out. There was incorrect permissions on the Omeka Archive Directory, which in turn was not allowing Omeka to access the newly uploaded photos. I am not sure when that happened but after I reset them things started working.

For some reason I kept getting the error message that Randtke was receiving using my original file but recreating the CSV seemed to resolve the Import Settings Expired error

Again Thanks for Your help

Glad it worked!