CSV 2.0 Not Working/Queued

We are attempting to use CSV 2.0 on a Omeka 2.0.1 installation. Our files keep getting an error and they show up as queued, no records imported. We ran the included "test.csv" and the following messages show in the error_log:

PHP Warning:  Invalid argument supplied for foreach() in /--/--/public_html/history/omeka/plugins/CsvImport/forms/Mapping.php on line 292
(above line 12 times for test.csv)
PHP Notice:  Undefined offset: 1 in /--/--/public_html/history/omeka/application/libraries/Omeka/Job/Process/Dispatcher.php on line 120
PHP Notice:  Undefined offset: 2 in /--/--/public_html/history/omeka/application/libraries/Omeka/Job/Process/Dispatcher.php on line 121

The following is our server environment:

PHP/Zend Info is as follows:

PHP 5.4.12 (cli) (built: Mar 15 2013 00:52:24)
Copyright (c) 1997-2013 The PHP Group
Zend Engine v2.4.0, Copyright (c) 1998-2013 Zend Technologies

Linux (CentOS) info:
Linux host2.--.-- 2.6.18-194.17.1.el5 #1 SMP Wed Sep 29 12:50:31 EDT 2010 x86_64 x86_64 x86_64 GNU/Linux

Apache2 info:

Server version: Apache/2.0.64
Server built:   Mar 15 2013 00:43:10
Cpanel::Easy::Apache v3.18.6 rev9999

MySQL info:
mysql Ver 14.12 Distrib 5.0.96, for unknown-linux-gnu (x86_64) using readline 5.1

I read through the other CSV 2.0 messages on the Troubleshooting forum and tried some of their "solutions", none of which worked. Also, we disabled and uninstalled all other plugins. We were not running the Social Bookmarking plugin which has appeared as a potential culprit in a number of messages.

Any help / suggestions would be appreciated!

Jim Metzger

This is a known, but still a bit mysterious, bug that we are working on chasing down. Thanks for the detailed info -- that should help us a lot.

If there are any other log / error files we can provide, please let us know here or by email. We dropped back to 1.5.3 in the meanwhile, but still have a 2.0.1 development platform available.


We have found an apparent solution for it, under the latest (2.0.2) release, from a post from a year ago. We missed it on our initial search.

It appears that Omeka gets lost auto-detecting the PHP CLI. Fix is to specify it.

In application/config/config.ini: 146-152

; background.php.path
; Path to PHP-CLI for running background processes.
; default: ""
; If left blank, Omeka will try to autodetect the right path. Set this
; to override the autodetected PHP path.
background.php.path = "/usr/local/bin/php"

CSV Import runs perfectly now.



Related Post: CSV Import Problem