Another CSV Import Error

Like an earlier poster, I am getting the error "Import settings expired. Please try again" when trying to upload a CSV file.

At first, I was getting this error when I tried to submit the second page of the CSV upload process (from the page where you map fields). I then tried the suggestion from the last forum poster, who said that the error might be coming from not having the CSV file encoded in UTF-8. I re-encoded it in UTF-8, and now the error occurs earlier: on submitting the first page of the import process.

Any ideas on what could be going wrong?

For reference, the earlier post is here:

Edit #1: I tried changing to Unicode encoding rather than UTF-8, and got to the second screen. Other errors appear when I try to upload however. I also see that extra characters (two question marks) have been added to the first row of data; these do not appear when I look at the CSV file in Notepad, but only after they are imported by CSV import tool.

Edit #2: I tried switching back to UTF-8 encoding with no other variables changed, and got the "Import settings expired. Please try again" error again, on the first page in the import process.

Update -- tried to edit the post again, but the post was too old, and it timed out.


Here is a comparison of what happens with the various encoding types, with no other variables introduced:

1. UTF-8: "Import settings expired. Please try again" on first screen of the import process.
2. Unicode: Extra characters (two question marks) are added to the first row of data; these do not appear when I look at the CSV file in Notepad, but only after they are imported by CSV import tool. The import process finishes, but the items fail to import.
3. ANSI encoding: No extra characters are added and the "Import settings expired" message does not appear. However, a new error appears, having to do with the server where the image files are not being reachable. The items do not import.

Is the underlying problem not the encoding of the CSV file, but the server where the image files are not being reachable? (It *should* be reachable in my case, but I can attack that problem separately.)

Just answered my own question. The problem was with a one-character error in one of the image file names. So -- it appears the the underlying problem did not have to do with encoding, but with Omeka being able to access all of the image files associated with the import.

And more... probably no one's reading these updates, but I feel compelled to write this down. Today I undid my previous exports, and tried re-importing exactly the same file as I used previously, but with an extra column of data. I got the "Import settings expired. Please try again" error once again. Now, nothing is working at all to fix this. I have tried breaking the import sheet down to its absolute bare bones -- only two columns and two rows of data -- and tried uploading in ANSI, UTF-8 and Unicode encoding formats. Nothing works. I am completely stumped and don't get any other error message than "Import settings expired," which does not help. Any ideas?

Oh yes, we are reading these, but as of 2 days ago you had resolved the issue which is why someone did not respond.

Have you tried deactivating and uninstalling the CSV plugin, and then reinstalling it?

Have you turned on the error message to display the full backtrace, if available?

Are all of the image file names correct for importing?

Are you running this on a web server or is this on a local installation?

Hi Sheila,

Thanks and I didn't mean to imply no one cares! Just that I wasn't sure anyone would be interested in more follow-ups about it.

I did not know about the "full backtrace" on the error message -- I'll try that next time, since it looks like it would provide more detail about what is going wrong.

The image file names were correct (I had fixed that the first time around). Our installation is being run on one of our university's web servers.

I had my IT person look at the problem I was having yesterday, and it appeared that the problem was either that I had something in my browser cache that was causing an error, or that the browser itself was the issue. I switched from Chrome to Firefox on her suggestion, and the problem went away. I'm not sure if it was Chrome's fault, or if there was just something cached that was causing the problem.

I'm hoping that seeing this process of error checking on the tool might be helpful to someone else seeing similar issues. Just to summarize the various things I corrected to make this import work...

- ANSI encoding of a CSV file (which is the default on my installation of Excel) appears to be fine
- Make sure your image file names in the CSV file are correct; a small error in one file name can prevent the import from happening
- There MIGHT be issues with Chrome and/or browser caching in the import. Try switching to another browser and/or clearing your cache.

Thanks for the update.

Just an FYI, I was having the same problem today, so I switched to FireFox and, voila, problem solved.

Thanks! FireFox works!

Hi all, FYI, when filenames are incorrect, items are imported up to that file it seems, so it'll tell you there was an error with importing (without specifying) but in actual fact some of the items are there, it just stops at the problem-file. At least this way it's easier to re-check the file paths.

I've also found that trailing white spaces can be problematic; excel does not have actual line breaks in cells, but when data is copied from Word, it adds a space, which re-appears as a line break in CSV files, and can prevent an import. (OS X at least).

And lastly, I've found a difference in jpg's to be a cause of import errors; on my server (well, through Filezilla) all .jpg's seem to be lowercase, turns out some were uppercase JPG's, especially when working with images supplied by others, this can happen often; a result of people using other software for saving jpg's or simply renaming png's to jpg etc.